Important: Employee Direct Deposit and Banking Information Have NOT Changed
Incident Report for Pitt IT Systems Status
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 12:33 EDT
Update
Pitt Information Technology investigated the issue thoroughly with the vendor for the University’s Pitt Worx service. We determined that the problem occurred because the vendor implemented an unscheduled system change that they did not communicate to the University. This change triggered an automated direct deposit notification.

We are working with the vendor to ensure that they properly communicate, schedule and test future system changes to prevent similar occurrences in the future.
Posted Apr 16, 2024 - 12:32 EDT
Monitoring
Many Pitt faculty, staff, and employees received an email in error this evening with the Subject “Direct Deposit Verification.” The email indicated that the recipient made a change to their University direct deposit information. This email was sent in error. Employee personal banking information and direct deposit remain unchanged.

Pitt IT is working with our vendor partners to identify the cause of the issue so that we can take steps to ensure it does not happen again. We are also working to send a clarification email to individuals who received the original message. We apologize for the inconvenience this message has caused.

Please contact the Technology Help Desk at +1-412-624-HELP (4357) if you have any questions regarding this announcement.
Posted Apr 13, 2024 - 21:48 EDT
This incident affected: Pitt Worx.