Issue Affecting Access to Enterprise Data Storage

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital has worked with the vendor to resolve the issue. Full service has been restored.

We continue to monitor the service closely to ensure continued reliability and stability. If you encounter any additional enterprise data storage issues, please report them to the Technology Help Desk.
Posted May 30, 2026 - 03:39 EDT

Update

Pitt Digital continues working with the vendor to resolve the issue and restore full service.
Posted May 30, 2026 - 03:12 EDT

Investigating

Pitt Digital is aware of an issue that is affecting access to Enterprise Data Storage (Dell Isilon), the University’s enterprise storage platform for hosting unstructured data, including file system data, audio, video, and business applications.

We are working with the vendor to resolve the issue and restore service as quickly as possible. Updates will be posted to status.pitt.edu as more details become available.
Posted May 30, 2026 - 02:15 EDT
This incident affected: Network, Hosting, and Storage (Enterprise Data Storage).