RESOLVED: Vendor Issue Affecting Phone Calls to Technology Help Desk

Incident Report for Pitt Digital Systems Status

Resolved

Monitoring confirms the issue is fully resolved.
Posted Sep 21, 2026 - 14:29 EDT

Monitoring

The vendor has resolved their issue that prevented individuals from reaching the Technology Help Desk by phone earlier today. Full Help Desk service has been restored. Pitt Digital continues to monitor the affected service closely to ensure continued reliability and stability.
Posted Sep 21, 2026 - 11:47 EDT

Investigating

Pitt Digital is aware of a vendor issue that is affecting the ability of customers to contact the Technology Help Desk by phone. Customers calling 412-624-HELP (4357) hear the standard greeting and are redirected to hold music after selecting an option. Pitt Digital is working with the vendor to resolve the issue and restore full service.

Customers can continue to contact the Help Desk by submitting a ticket, chatting online, or via email (https://www.digital.pitt.edu/support). Updates will be posted to status.pitt.edu as more information becomes available.
Posted Sep 21, 2026 - 11:07 EDT
This incident affected: IT Support Services (Technology Help Desk).