Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2023 - 01:00 EDT
Scheduled
LastPass, the provider for the University’s Password Manager and vault app, will perform scheduled maintenance early this Saturday. From 1 to 7 a.m. on Sept. 16, users may experience service disruptions accessing their LastPass account vault — where all passwords and secure notes are stored. This routine maintenance is necessary to maintain the security, stability, and reliability of the LastPass service. For updates about the scheduled maintenance, visit LastPass.
Separately, beginning in mid-October, LastPass will require master passwords to be a minimum of 12 characters that include at least one number, one lowercase letter, one uppercase letter, and one special character. Users whose master passwords do not meet these complexity requirements will be prompted by LastPass to update their master passwords. Pitt IT will share this information with students, faculty, and staff who have LastPass accounts.
Please contact the 24/7 IT Help Desk at +1-412-624-HELP (4357) if you have any questions about this announcement.
Posted Sep 13, 2023 - 15:52 EDT
This scheduled maintenance affected: Accounts, Access, and Information Security (LastPass Password Manager).