Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2025 - 08:00 EDT
Scheduled
Pitt Information Technology has scheduled maintenance to upgrade Microsoft’s Configuration Manager ― formerly known as MECM and System Center Configuration Manager ― from 8 a.m. to 2 p.m. on Sunday, June 1.
University units that subscribe to Pitt IT’s Enterprise Device Management (EDM) service will be temporarily unable to use Configuration Manager to build machines, run reports, and push software updates to Windows devices during the maintenance window.
This upgrade is necessary to provide support for new releases of Windows and ensure continued support from the vendor. Pitt IT selected the maintenance period after careful consideration of customer usage patterns to minimize service downtime. Individuals do not need to take any action before or after the upgrade.
To ensure a smooth transition, Pitt IT will be monitoring the progress during the scheduled maintenance. In the event that an issue or problem arises, the service will revert to its original configuration and Pitt IT will post an update to status.pitt.edu.
Please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357) if you experience any issues or have questions related to this maintenance. This effort is being led by Jeremiah Airhart, Pitt IT’s manager of infrastructure and operations.
Posted May 27, 2025 - 09:08 EDT
This scheduled maintenance affected: Printing, Desktop and Mobile Computing, and Software (Enterprise Device Management).