Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2024 - 23:00 EST
Scheduled
Network maintenance may briefly affect PittNet wired and Wi-Fi service from 11:00-11:30 p.m. on Friday, Nov. 8, in the following locations on the Pittsburgh campus: • Darragh (first floor) This maintenance is part of vendor-required best practices to ensure the continued security, stability, and reliability of older network hardware components. Pitt IT has completed checks to ensure that the hardware is ready for the maintenance and will be actively engaged with the vendor throughout the maintenance period. Please submit a request to the Technology Help Desk or call +1-412-624-HELP (4357) if you have any questions about this announcement.
Posted Nov 07, 2024 - 11:21 EST
This scheduled maintenance affected: PittNet Wi-Fi and Wired Networks (PittNet Wired Network, PittNet Wi-Fi, Pitt Guest Wi-Fi).