Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 22:00 EDT
Scheduled
Pitt Worx will be unavailable from Friday, March 21, at 10 p.m., until Sunday, March 23, at 7 p.m. ET while the vendor (Oracle) performs payroll maintenance. Those who need to submit timecards for the week of March 16-22 should plan to do so before or after the outage period. As a reminder, timecards must be submitted and approved by noon on Monday, March 24.
This maintenance period was determined according to Oracle’s payroll legislative patches schedule and includes system updates to legislative functions for local, state, and federal tax changes for 2025. These functionalities have been tested and approved for migration by Payroll department users.
The HCM Solutions Team has completed checks to ensure that the system is ready for the updates. In the unlikely event of an issue, the HCM Solutions Team will closely collaborate with Oracle to determine the cause and resolve the issue. If the outage period is extended, updates will be provided at https://status.pitt.edu/.
Please contact the Technology Help Desk by calling +1-412-624-HELP if you experience any issues or have any questions regarding this maintenance. This effort is being led by John Scifo, Pitt IT’s manager of enterprise HCM applications.
For questions about using Pitt Worx and Talent Center, please submit an inquiry to the Office of Human Resources at https://hr.pitt.edu/contact-ohr.
Posted Mar 17, 2025 - 11:42 EDT
This scheduled maintenance affected: Human Resources and Financial Systems (Pitt Worx).