Service Provider Issue Affecting Access to Pitt Mobile
Incident Report for Pitt IT Systems Status
Resolved
The service provider confirms the issue has been fully resolved.
Posted Apr 29, 2024 - 08:39 EDT
Monitoring
Pitt Information Technology is aware of an intermittent issue that may be affecting access to Pitt Mobile.

Pitt IT is working with the service provider to restore full service as quickly as possible. The service provider has implemented a fix and is monitoring the issue now. Updates will be posted to status.pitt.edu as more information becomes available.

Please contact the Technology Help Desk at +1-412-624-HELP if you have any questions regarding this announcement.
Posted Apr 26, 2024 - 15:00 EDT
This incident affected: Pitt Mobile (ReadyEducation).