Resolved: Issue Affected PittNet Wi-Fi Service in Pittsburgh Campus Locations

Incident Report for Pitt Digital Systems Status

Resolved

Monitoring confirms the issue has been resolved.
Posted May 21, 2026 - 12:09 EDT

Investigating

Pitt Digital has resolved a network issue that affected PittNet Wi-Fi service in buildings on the Pittsburgh campus earlier this morning. PittNet wired service and MyResNet Wi-Fi were not affected. The issue has been addressed and full service has been restored.

The service interruption was caused by an issue with the University’s legacy wireless hardware, which is being replaced and upgraded as part of Pitt Digital’s network modernization initiative.

Pitt Digital continues to closely monitor the service to ensure continued reliability and stability. We are committed to providing the best possible support to the University community and apologize for any disruptions caused by this outage. Additional updates will be posted to status.pitt.edu as needed.
Posted May 21, 2026 - 08:18 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wi-Fi).