Update: My Pitt Back Online
Incident Report for University of Pittsburgh
Resolved
The issue that affected My Pitt earlier today has been resolved and full service has been restored.
Posted Feb 14, 2020 - 14:39 EST
Monitoring
Pitt Information Technology has taken steps to address the issue that affected access to My Pitt (my.pitt.edu). My Pitt is back online, and we are continuing to monitor it. Additional updates will be posted as they become available.
Posted Feb 14, 2020 - 11:30 EST
Investigating
Pitt Information Technology is investigating an issue that is affecting access to My Pitt (my.pitt.edu). Affected users are unable to view the My Pitt landing page after entering their login credentials. In the interim, note that many tasks accessed through My Pitt are also available by searching tasks at AskCathy.pitt.edu. Individuals may also access their Pitt email and calendar by selecting Outlook at portal.office.com.

Pitt Information Technology is working to restore full service as quickly as possible. Updates will be posted as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Feb 14, 2020 - 09:55 EST
This incident affected: My Pitt website (my.pitt.edu).