Pitt Digital has worked with our vendor partner to resolve the issue that affected new logins to University services through Pitt Passport single sign-on. We are working with our vendor to identify the issue’s root cause and take steps to address it.
We are committed to providing the best possible support to the University community and apologize for any disruptions caused by this outage.
For the latest updates on known issues and planned service maintenance periods, visit status.pitt.edu. Should you encounter any other issues using services provided by Pitt Digital, please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357).
Posted Jan 29, 2026 - 16:36 EST
Monitoring
Pitt Digital’s vendor partner has taken steps to mitigate the issue affecting new logins to Pitt Passport. The mitigation measures appear to have restored full service to affected users.
Pitt Digital continues to closely monitor Pitt Passport logins to assess stability and reliability. If you continue to experience issues logging in to University services that use Pitt Passport, please report them to the Technology Help Desk at +1-412-624-HELP (4357) so that we can investigate and respond accordingly.
Posted Jan 29, 2026 - 14:24 EST
Update
Pitt Digital continues working with our vendor partner to resolve the issue affecting new logins through Pitt Passport and restore full service. Updates will continue to be posted to status.pitt.edu
Posted Jan 29, 2026 - 13:44 EST
Investigating
Pitt Digital is aware of an issue that is affecting the ability of individuals to log in to University services through Pitt Passport single sign-on. The issue affects new login attempts and displays an error message that states the login was not successful. Those who are already logged in to a service are not affected.
We are working with our vendor partner to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Jan 29, 2026 - 12:43 EST
This incident affected: Login Services (Pitt Passport Single Sign-On).