Service Provider Issue Affecting Concur Travel and Expense Management
Incident Report for Pitt IT Systems Status
Resolved
Monitoring confirms the issue has been resolved.
Posted Mar 05, 2024 - 08:25 EST
Monitoring
The service provider has taken steps to address the issue and restore service. Pitt IT continues to monitor Concur Travel and Expense Management and will post additional updates to status.pitt.edu as needed.
Posted Mar 04, 2024 - 10:14 EST
Identified
The service provider continues to work on a resolution to the issue affecting Concur Travel and Expense Management.
Posted Mar 04, 2024 - 09:56 EST
Investigating
Pitt Information Technology is aware of a service provider issue that is affecting access to the Concur Travel & Expense System.

The service provider is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.

Please contact the Technology Help Desk at +1-412-624-HELP if you have any questions regarding this announcement.
Posted Mar 04, 2024 - 07:49 EST
This incident affected: Concur Travel & Expense.