Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 06, 2026 - 21:00 EDT
Scheduled
In alignment with Microsoft's move to stronger encryption standards, Pitt Digital will begin blocking an outdated login encryption method called RC4 at the University on Saturday, June 6. This change helps protect account security for the Pitt community.
This change should have no impact on students, faculty, and staff. Pitt Digital proactively identified and worked directly with the very small number of account owners still using RC4 to ensure they are updated and well prepared for a smooth transition.
Please submit a ticket to the Technology Help Desk at https://digital.pitt.edu/helprequest or call +1-412-624-HELP (4357) if you have questions.
Posted Jun 01, 2026 - 16:41 EDT
This scheduled maintenance affected: Login Services (Enterprise Active Directory).