Monitoring confirms the issue has been fully resolved.
Posted Sep 25, 2026 - 14:54 EDT
Monitoring
Microsoft has resolved their issue that affected the ability of some Teams desk phones to make and receive calls earlier this morning. Full service has been restored. Pitt Digital continues to monitor the service closely to ensure continued reliability and stability.
Posted Sep 25, 2026 - 07:47 EDT
Investigating
Pitt Digital is aware of a Microsoft issue that is affecting the ability of some Teams desk phones to make and receive calls.
As a workaround, Teams desk phone users can use the Teams app on their computer or mobile device to place and receive calls. This issue does not affect calling via the Teams app or legacy Avaya desk phones.
Pitt Digital is working with the vendor to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Sep 25, 2026 - 02:21 EDT
This incident affected: Communication and Collaboration (Voice and Data Services (Telephony)).