Intermittent Issue Affecting Access to PeopleSoft
Incident Report for Pitt IT Systems Status
Resolved
Monitoring confirms the issue has been resolved.
Posted Mar 20, 2024 - 17:48 EDT
Monitoring
Our service providers have worked to address the issue that affected PeopleSoft earlier today. Access has been restored. Pitt IT continues to monitor the issue and will post additional updates to status.pitt.edu as needed.
Posted Mar 19, 2024 - 17:28 EDT
Investigating
Pitt Information Technology is aware of an intermittent issue that is affecting access to the PeopleSoft Student Information System.

Pitt IT is working with the service provider to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.

Please contact the Technology Help Desk at +1-412-624-HELP if you have any questions regarding this announcement.
Posted Mar 19, 2024 - 14:32 EDT
This incident affected: Student Information System (PeopleSoft).