Service Provider Issue Affecting Salesforce Request Forms
Incident Report for Pitt IT Systems Status
Resolved
Pitt IT's monitoring confirms that the service provider has fully resolved the issue.
Posted Nov 23, 2022 - 12:04 EST
Monitoring
The service provider has taken steps to mitigate the issue and restore service. Pitt IT continues to monitor the service and will post additional updates as needed.
Posted Nov 22, 2022 - 13:09 EST
Identified
Pitt IT is aware of a service provider issue that is affecting the ability of users to submit Salesforce customer request forms. Affected forms include some Help Desk request forms, COVID vaccination status forms, recruiting information request forms, Panther Central forms, and some Human Resources forms.

Pitt IT is working with the service provider to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Nov 22, 2022 - 12:19 EST
This incident affected: Enterprise Relationship Management (Salesforce) (ERM Service Desk (Salesforce Service Cloud), ERM Recruiting (Salesforce Marketing Cloud)).