Vendor Issue Affecting Virtual Computing Lab and Other Azure Services

Incident Report for Pitt Digital Systems Status

Resolved

Microsoft has fully resolved their issue and restored service. Pitt Digital continues to closely monitor affected services and will post any additional updates to status.pitt.edu.
Posted Oct 29, 2025 - 20:50 EDT

Monitoring

Microsoft has taken steps to mitigate their issue and restore service. Pitt Digital has observed that affected University services are now recovering, including the Virtual Computing Lab, enterprise virtual desktop hosting, and PittGPT. Microsoft expects full recovery of all affected services by early this evening.

Pitt Digital continues to closely monitor all affected services and will post additional updates to status.pitt.edu.
Posted Oct 29, 2025 - 17:10 EDT

Update

Microsoft continues working to resolve the issue and restore service for all affected customers. Updates will be posted to status.pitt.edu.
Posted Oct 29, 2025 - 16:05 EDT

Update

The Microsoft Azure issue is also causing issues with scheduling Zoom meetings through Outlook. Zoom service is not directly impacted, and previously scheduled meetings and webinars are still available.

Individuals should join or launch Zoom meetings through the Zoom client or via the web (instead of through Outlook). To do so, use these steps:

1. Log in to your Zoom account
2. From the Zoom client, Select Profile, then Meetings or Webinars. If you are using Zoom on the Web, select 'Meetings' to see your scheduled events.
3. Locate the upcoming meeting, select 'Start", copy and provide the meeting ID to meeting participants, or schedule a new meeting.

Other third-party Microsoft connectors are also be affected (for example, Docusign and Salesforce add-ins within Microsoft Outlook are currently unavailable).
Posted Oct 29, 2025 - 14:48 EDT

Update

Microsoft continues working to resolve the issue and restore service. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Oct 29, 2025 - 14:08 EDT

Update

This issue also affects access to PittGPT and may also affect Azure cloud subscriptions used by some customers. Microsoft continues working to resolve their issue, which affects customers beyond the University of Pittsburgh.
Posted Oct 29, 2025 - 13:12 EDT

Investigating

Microsoft is experiencing an issue with Azure that is affecting access to the Virtual Computing Lab, enterprise virtual desktop hosting, and other Azure services. Microsoft 365 services — including OneDrive and Pitt Email — are not impacted by this issue.

Students can still access the Virtual Computing Lab through the local client installed on the computing labs. Individuals affected by the issue can also install the Windows app through the Windows store.

Pitt Digital is working with the vendor to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.

Please submit a request to the Technology Help Desk or call +1-412-624-HELP (4357) if you have any questions about this announcement.
Posted Oct 29, 2025 - 12:34 EDT
This incident affected: Printing, Desktop and Mobile Computing, and Software (Computing Labs / Virtual Lab, Enterprise Virtual Desktop Hosting).