Update on PeopleSoft Cybersecurity Incident

Incident Report for Pitt Digital Systems Status

Resolved

The issue has been resolved. Sierra Cedar continues to monitor the environment closely, and any additional updates will be posted to status.pitt.edu.
Posted Jun 15, 2026 - 09:05 EDT

Monitoring

Pitt Digital can report that Sierra Cedar, the University’s PeopleSoft service provider, has completed remediation efforts related to yesterday's cybersecurity incident. PeopleSoft is fully available and safe to use.

Sierra Cedar has also completed security scans across Pitt’s environment and has found no evidence of compromise or active exploitation related to this vulnerability. They continue to monitor the environment closely and will notify the University should that status change.

Pitt Digital will continue to post updates to status.pitt.edu as more information becomes available. In the meantime, please contact the Technology Help Desk at +1-412-624-HELP (4357) if you have any questions related to this announcement.
Posted Jun 12, 2026 - 16:09 EDT

Update

Sierra Cedar has finished their work on the servers. Individuals may resume logging in to and using PeopleSoft. Additional updates will be posted to status.pitt.edu as more information becomes available.
Posted Jun 11, 2026 - 19:22 EDT

Update

Sierra Cedar, the University’s PeopleSoft service provider, will be rebooting servers beginning at 4 p.m. this afternoon as part of its mitigation efforts to address the PeopleSoft cybersecurity incident. We expect the maintenance to last up to two hours.

Pitt Digital recommends that individuals remain logged out of the system until maintenance is complete. PeopleSoft users may experience outages or be disconnected from the system while maintenance is underway. If you must remain logged in to PeopleSoft and are actively entering data or completing transactions, be sure to save your work often to avoid losing unsaved progress.

We will post another update to status.pitt.edu once Sierra Cedar has completed their work.
Posted Jun 11, 2026 - 15:33 EDT

Investigating

Pitt Digital is aware of a cyber incident affecting a broad range of PeopleSoft customers across a number of institutions. Sierra Cedar, the University’s PeopleSoft service provider, is actively working to mitigate the impact and has begun taking steps to address the threat. Pitt Digital is investigating the extent to which Pitt’s PeopleSoft environment may be impacted and will follow up on the findings of that investigation.

As part of the incident response, Sierra Cedar will be rebooting servers, which will cause intermittent service disruptions throughout the day today. PeopleSoft users may experience outages or be disconnected from the system. If you are actively entering data or completing transactions in PeopleSoft, be sure to save your work often to avoid losing unsaved progress.

We will provide updates on status.pitt.edu as the situation develops, including expected start and end times for the maintenance if possible.
Posted Jun 11, 2026 - 13:13 EDT
This incident affected: PeopleSoft/HighPoint CX (Student Information System).