RESOLVED: Power Issue Briefly Affected PittNet Service in Holland Hall, Panther Central, University Store on Fifth

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital is aware of a power issue that affected PittNet Wi-Fi and wired service to Holland Hall, Panther Central, and the University Store on Fifth between approximately 6:05 and 6:35 p.m. this evening.

Pitt Digital worked with our partners to restore service and is closely monitoring all affected services to ensure their continued stability and reliability. Any additional updates will be posted to status.pitt.edu as needed.
Posted Feb 17, 2026 - 18:53 EST
This incident affected: Wired and Wi-Fi Networks (PittNet Wired Network, PittNet Wi-Fi).