RESOLVED: Commercial Power Provider Outage Cause of Greensburg Campus Network Service Interruption

Incident Report for Pitt IT Systems Status

Resolved

Monitoring confirms the issue has been resolved.
Posted Apr 16, 2025 - 06:48 EDT

Monitoring

Pitt IT has worked with our service provider partners to fully restore wired network service to the Greensburg campus. We continue to monitor service closely and will post any additional updates to status.pitt.edu.
Posted Apr 15, 2025 - 18:03 EDT

Identified

A commercial power provider serving the University of Pittsburgh at Greensburg campus experienced a weather-related issue that disrupted power to the campus this afternoon, affecting a wide variety of services, including PittNet Wired. The provider has restored power to the campus and affected services are coming back online. PittNet Wi-Fi and voice services are fully restored. PittNet Wired service is still in the process of being restored and will be available again soon.

Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience any network issues.
Posted Apr 15, 2025 - 16:26 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wired Network).