TeamDynamix has rolled back the new version of the TDX interface to address the performance issues that affected TDXNext earlier today. This step has resolved the issue and restored full functionality.
Pitt IT continues to monitor the service closely and will post any additional updates to status.pitt.edu. Once the vendor has scheduled another date to launch the new user interface, Pitt IT will update the University community.
If you continue to experience issues using TDX, please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357) to report them.
Posted Jun 02, 2025 - 22:10 EDT
Update
The vendor reports they are getting closer to resolving the issue and restoring full service. Additional updates will be posted to status.pitt.edu.
Posted Jun 02, 2025 - 11:38 EDT
Update
Then vendor continues working to resolve the issue, which is affecting customers beyond the University of Pittsburgh.
Posted Jun 02, 2025 - 10:06 EDT
Investigating
Pitt Information Technology is aware of an issue that is causing slower than expected performance for the TeamDynamix ticketing application (TDNext). Affected individuals may experience slowness when accessing the application, switching between tickets, and loading application tabs. The University of Pittsburgh’s Services Portal and Knowledge Base at services.pitt.edu are not affected by the issue at this time.
Pitt IT is working with the vendor to resolve the issue and restore full service. Updates will be posted to status.pitt.edu as more details become available.
Posted Jun 02, 2025 - 08:56 EDT
This incident affected: Administrative and Business Systems (TeamDynamix).