The vendor has resolved their issue and restored full access. Pitt Digital continues to monitor the affected service closely to ensure continued reliability and stability.
Posted Aug 25, 2026 - 18:48 EDT
Update
The vendor continues working to resolve the issue affecting myPitt, which is affecting customers beyond the University of Pittsburgh. Updates will be posted to status.pitt.edu.
Posted Aug 25, 2026 - 17:19 EDT
Investigating
Pitt Digital is aware of an intermittent vendor issue that is affecting the ability of some individuals to access myPitt (my.pitt.edu).
University services you may typically access via myPitt can still be accessed through their direct URL (for example, canvas.pitt.edu, software.pitt.edu or accounts.pitt.edu). Direct links to many popular services are also available in the footer of the digital.pitt.edu website.
Pitt Digital is working with the vendor to resolve the issue, which is affecting customers beyond the University of Pittsburgh. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Aug 25, 2026 - 15:21 EDT
This incident affected: Communication and Collaboration (myPitt (my.pitt.edu)).