Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 18, 2025 - 21:01 EDT
Scheduled
Pitt Information Technology and our vendor partners will perform network upgrades on Friday that will result in the following service disruptions between 9 and 11 p.m. on Friday, April 18:
• Connections to the Pittsburgh Supercomputing Center (PSC) and the ScienceDMZ, as well as Xfinity TV service in University residence halls, will be briefly unavailable for up to 10 to 20 minutes
• Individuals may also experience slight delays in internet traffic for up to 20 minutes, resulting in slower loading times for external websites and streaming services
This work is needed to migrate the Pitt internet services to new firewalls that will enhance security, performance, and reliability of the network. Individuals do not need to take any action after the upgrade is completed.
Pitt IT has completed checks to ensure that systems are ready for the upgrade and will be actively engaged with the vendor throughout the maintenance period. In the unlikely event that an issue or problem arises, the vendor will revert to its original network configuration and Pitt IT will send an email notification as well as post an update to status.pitt.edu.
Please call the Technology Help Desk at +1-412-624-HELP (4357) if you have any questions or experience issues related to this maintenance. This effort is being led by Lou Passarello, Pitt IT’s director of operations.
Posted Apr 14, 2025 - 15:47 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, PittNet Wi-Fi).