Commercial Power Provider Outage Cause of Johnstown Campus Network Service Interruption

Incident Report for Pitt IT Systems Status

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 11:22 EDT

Monitoring

A commercial power provider serving the University of Pittsburgh at Johnstown campus experienced an issue that disrupted power to the campus this morning, affecting a wide variety of services including PittNet Wired and Wi-Fi. The provider has restored power to the campus and affected services are coming back online. PittNet Wired and Wi-Fi service should be fully restored in all locations within approximately twenty minutes.

Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience any network issues after power has been restored.
Posted Mar 13, 2025 - 11:17 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wired Network, PittNet Wi-Fi).