Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 20, 2026 - 21:00 EDT
Scheduled
Pitt Digital will update the University’s PittNet Wi-Fi security certificate at 9 p.m. on Saturday, June 20, as part of our annual renewal to maintain wireless security. Wi-Fi services will remain uninterrupted during the renewal.
To maintain secure access to PittNet Wi-Fi, trust or accept the renewed certificate if prompted when connecting to PittNet Wi-Fi for the first time after June 20. See reconnecting to PittNet after certificate updates for step-by-step instructions: https://services.pitt.edu/TDClient/33/Portal/KB/ArticleDet?ID=1330.
Select these updated network names when connecting new devices in areas upgraded to Wi-Fi 6 infrastructure (full list available at: https://www.digital.pitt.edu/wifi#list) as part of Pitt Digital’s ongoing network modernization initiative:
• PittNet (alternative to WIRELESS PITTNET) • Pitt Guest Wi-Fi (alternative to PITT GUEST WI-FI)
Both current and legacy names will continue to function until Pitt Digital communicates retirement timelines with ample advance notice.
Please submit a ticket to the Technology Help Desk at https://digital.pitt.edu/helprequest or call +1-412-624-HELP (4357) if you experience any issues or have questions related to this change.
Posted Jun 16, 2026 - 13:35 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wi-Fi, Pitt Guest Wi-Fi).