Intermittent Vendor Issue Affected myPitt Access

Incident Report for Pitt IT Systems Status

Resolved

Monitoring confirms the issue that briefly affected myPitt early this morning has been fully resolved.
Posted May 27, 2025 - 15:12 EDT

Monitoring

Pitt Information Technology is aware of an intermittent vendor issue that affected the ability of some individuals to access myPitt (my.pitt.edu) earlier this morning. The vendor has resolved the issue, which affected customers beyond the University of Pittsburgh. Full service has been restored.

Individuals who experienced the issue may need to clear their web browser cache before they can access myPitt. Pitt IT continues to monitor the service closely and will post any additional updates to status.pitt.edu.

Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience issues accessing myPitt.
Posted May 27, 2025 - 05:20 EDT
This incident affected: Communication and Collaboration (myPitt (my.pitt.edu)).