Intermittent Issue Affecting Access to My Pitt
Incident Report for Pitt IT Systems Status
Resolved
Pitt IT has confirmed that the service provider has fully resolved the issue that affected access to My Pitt (my.pitt.edu) earlier this morning. Full functionality has been restored.
Posted Oct 23, 2020 - 13:04 EDT
Monitoring
The service provider has resolved the issue that affected access to My Pitt (my.pitt.edu) earlier this morning. Pitt IT is continuing to monitor the service to confirm full functionality has been restored.
Posted Oct 23, 2020 - 11:28 EDT
Investigating
Pitt Information Technology is aware of an intermittent issue affecting access to My Pitt (my.pitt.edu). We are working with the vendor to restore full functionality as quickly as possible. Updates will be posted to status.pitt.edu as they become available.

Services can still be accessed through their direct URL (for example, software.pitt.edu or accounts.pitt.edu). Direct links to some IT services are also available in the footer of the technology.pitt.edu website.

Please contact the 24/7 IT Help Desk at 412-624-HELP (4357) if you have any questions regarding this announcement.
Posted Oct 23, 2020 - 10:47 EDT
This incident affected: My Pitt website (my.pitt.edu).