Pitt Digital has implemented a fix for the issue affecting the ability to log in to the Software Download Service (software.pitt.edu). The service is available and performing as expected. We continue to monitor closely to confirm the issue is fully resolved and will post any additional updates to status.pitt.edu.
Posted Jul 10, 2026 - 11:57 EDT
Identified
Pitt Digital is investigating an intermittent issue affecting the ability to log in to the Software Download Service (software.pitt.edu). Some users may be able to log in successfully while others experience errors.
Posted Jul 10, 2026 - 11:14 EDT
Monitoring
Pitt Digital identified an issue that briefly prevented some users from logging in to the Software Download Service (software.pitt.edu). The issue has been resolved and Pitt Digital is continuing to monitor the service. If you experience further issues, please contact the Technology Help Desk at +1-412-624-HELP (4357).
Posted Jul 10, 2026 - 11:04 EDT
This incident affected: Printing, Desktop and Mobile Computing, and Software (Software Download Service (software.pitt.edu)).