Monitoring confirms the issue has been fully resolved.
Posted Jan 26, 2026 - 18:37 EST
Monitoring
Access to HighPoint Degree Planner has been restored, and all Student Information System (PeopleSoft) functionality is now available. Pitt Digital continues to closely monitor the service to ensure continued stability and reliability and will post additional updates to status.pitt.edu as needed.
Posted Jan 26, 2026 - 11:42 EST
Identified
Pitt Digital has worked with our vendor partner to mitigate the intermittent issue that affected some Student Information System (PeopleSoft) functionality earlier this morning. Full service has been restored to most of the affected features. We continue working to resolve one outstanding issue that is preventing students and advisors from accessing HighPoint Degree Planner. Updates will continue to be posted to status.pitt.edu.
Posted Jan 26, 2026 - 10:07 EST
Investigating
Pitt Digital is aware of an issue that is affecting some functionality within the Student Information System (PeopleSoft). We are investigating the issue to determine its scope and which features are affected.
Pitt Digital is working with our vendor partner to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Jan 26, 2026 - 08:23 EST
This incident affected: PeopleSoft/HighPoint CX (Student Information System).