Issue Affecting Access to Pitt Email for Some Pitt Students
Incident Report for Pitt IT Systems Status
Resolved
Monitoring confirms that the issue has been fully resolved.
Posted Apr 15, 2024 - 11:35 EDT
Monitoring
Pitt IT has taken steps to resolve the issue that affected Pitt Email access for some University of Pittsburgh students. Access to Pitt Email has now been restored for all affected students. No email messages were lost as a result of this issue.

We understand the importance of email to Pitt students and apologize for the inconvenience this issue caused. We are working with Microsoft — the service provider for Pitt Email — to identify the root cause of the issue and take steps to ensure that it does not occur again.

Pitt IT continues to closely monitor Pitt Email service and will post any additional updates to status.pitt.edu. Once a root cause has been determined, a summary will also be posted to status.pitt.edu.

If you have questions in the meantime or continue to experience email issues, please contact the Technology Help Desk at +1-412-624-HELP so that we can immediately work with you to address it.
Posted Apr 13, 2024 - 11:50 EDT
Investigating
Pitt Information Technology is aware of an issue that is affecting access to Pitt Email for some Pitt students. Email access for Pitt faculty and staff is not affected.

Pitt IT has identified the cause of the issue and taken steps to address it. Access to Pitt Email is now in the process of being restored but will take time to propagate to all affected students. Access for some students has already been restored, and access to all students should be restored by approximately noon today. No email messages were lost as a result of this issue.

Updates will be posted to status.pitt.edu as more information becomes available. Please contact the Technology Help Desk at +1-412-624-HELP if you have any questions regarding this announcement.
Posted Apr 13, 2024 - 10:40 EDT
This incident affected: Email (Pitt Email and Calendar).