A system restart has been completed and performance restored in Talent Center.
Posted Apr 16, 2025 - 17:02 EDT
Identified
Pitt Information Technology is aware of an intermittent service provider (Oracle) issue that is affecting access to Talent Center, including Talent Center for Managers and Talent Center: Careers at Pitt. Users may be able to log in to Talent Center, but encounter an error or constant loading of a module once logged in.
Pitt IT’s HCM Solutions team is working with the service provider to resolve the issue as quickly as possible and restore full service. Updates will be posted to http://status.pitt.edu as more information becomes available.
For questions or concerns about Talent Center, please submit an inquiry to the Office of Human Resources at https://hr.pitt.edu/contact-ohr.
Posted Apr 16, 2025 - 16:09 EDT
This incident affected: Human Resources and Financial Systems (Talent Center).