Monitoring confirms that the issue has been fully resolved.
Posted Apr 21, 2025 - 17:13 EDT
Monitoring
Access to myPitt (my.pitt.edu) has been restored. Individuals who experienced the issue may need to clear their web browser cache before they can access myPitt.
Pitt IT continues to monitor the service closely and will post any additional updates to status.pitt.edu.
Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience issues accessing myPitt.
Posted Apr 21, 2025 - 12:19 EDT
Update
Pitt IT continues working with our service provider to investigate and troubleshoot the intermittent issue affecting myPitt (my.pitt.edu) for some individuals. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Apr 21, 2025 - 12:05 EDT
Investigating
Pitt Information Technology is aware of an intermittent service provider issue that is affecting the ability of some individuals to access myPitt (my.pitt.edu). The issue appears to be a recurrence of a similar issue from April 16 and affects customers beyond the University of Pittsburgh.
As a workaround, individuals experiencing the issue can try clearing their web browser cache or using a private/incognito browser window. Please note that University services you may typically access via myPitt can still be accessed through their direct URL (for example, software.pitt.edu or accounts.pitt.edu). Direct links to many popular IT services are also available in the footer of the technology.pitt.edu website.
Pitt IT is working with the service provider to resolve the issue as quickly as possible and restore full service. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Apr 21, 2025 - 10:37 EDT
This incident affected: Communication and Collaboration (myPitt (my.pitt.edu)).