Vendor Issue Affecting Concur Travel & Expense Performance

Incident Report for Pitt IT Systems Status

Resolved

The vendor has resolved the issue affecting Concur and restored full service. Pitt IT continues to monitor the service closely and will post additional updates to status.pitt.edu as needed.
Posted Jul 09, 2025 - 16:41 EDT

Investigating

Pitt Information Technology is aware of a vendor issue that is causing slower than expected performance and errors when using the Concur Travel & Expense service.

The vendor is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Jul 09, 2025 - 14:56 EDT
This incident affected: Human Resources and Financial Systems (Concur Travel & Expense).