Intermittent Issue Affecting DocuSign Email Notifications
Incident Report for Pitt IT Systems Status
Resolved
Pitt IT's mitigation measures have been successful in restoring DocuSign service. The service provider continues working to identify and resolve the root cause of the issue. Pitt IT will continue to monitor the service closely and post any additional updates to status.pitt.edu as needed.
Posted Jan 13, 2025 - 17:26 EST
Update
Pitt IT's mitigation measure remain in place to deliver DocuSign email notifications to University of Pittsburgh customers while the service provider continues working to resolve the root issue.
Posted Jan 13, 2025 - 10:28 EST
Update
DocuSign continues working to resolve the root cause of the issue that affected email notifications for signed/completed documents.
Posted Jan 12, 2025 - 21:25 EST
Update
DocuSign is still working to resolve the root cause of the issue that affected email notifications for signed/completed documents. Pitt IT continues to closely monitor the service.
Posted Jan 12, 2025 - 16:25 EST
Monitoring
DocuSign continues working to resolve the root cause of the issue that affected email notifications for signed/completed documents. Pitt IT continues to closely monitor the service.
Posted Jan 12, 2025 - 09:18 EST
Update
Pitt Information Technology has taken steps to mitigate a DocuSign issue that earlier today prevented some individuals from receiving email notifications from Microsoft Office365 for signed/completed documents.

Email notifications from verified DocuSign senders that previously were quarantined have been delivered to University email addresses, and future DocuSign email notifications should be received by users as expected.

Pitt IT continues to work with DocuSign to identify and resolve the root cause of this service provider issue. Updates will be posted to status.pitt.edu as more information becomes available.

Reminder: If you were expecting a DocuSign notification and have not received it, please visit your Spam and Virus Filter at myPitt to check if it has been quarantined.

Please call the Technology Help Desk at +1-412-624-HELP (4357) if you have any questions about this announcement
Posted Jan 11, 2025 - 20:07 EST
Investigating
DocuSign is currently aware of and addressing an issue affecting email notifications for signed/completed documents. In some cases, individuals are not receiving email notifications from Microsoft Office365 for signed/completed documents. If you were expecting a DocuSign notification and have not received it, please visit your Spam and Virus Filter at myPitt to check if it has been quarantined.

Pitt Information Technology has also seen some cases of individuals receiving multiple email notifications from Microsoft Office365 for the same signed/completed document.

Pitt IT is working with the service provider to resolve the issue as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.

Please call the Technology Help Desk at +1-412-624-HELP (4357) if you have any questions about this announcement
Posted Jan 11, 2025 - 13:00 EST
This incident affected: Administrative and Business Systems (DocuSign).