Intermittent Service Provider Issue May Affect Qualtrics Access for Some Users
Incident Report for Pitt IT Systems Status
Resolved
Qualtrics reports that it has resolved the issue and restored full service.
Posted Nov 15, 2024 - 13:07 EST
Investigating
Pitt Information Technology is aware of an intermittent issue that the service provider indicates has a low potential to impact Qualtrics access. The issue affects individuals beyond the University of Pittsburgh. Users who encounter the issue may be able to resolve it by refreshing their web browser.

Pitt IT is working with the service provider to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.

Please submit a request to the Technology Help Desk or call +1-412-624-HELP (4357) if you have any questions about this announcement.
Posted Nov 15, 2024 - 11:00 EST
This incident affected: Online Survey System (Qualtrics).