RESOLVED: Issue Affected Submission of Some Pitt Print Jobs

Incident Report for Pitt Digital Systems Status

Resolved

Monitoring confirms the issue has been fully resolved.
Posted Aug 23, 2025 - 12:54 EDT

Monitoring

Pitt Digital has taken action to resolve an issue that earlier today affected the ability of some students to submit print jobs using the Pitt Print client on their computer. The issue affected only students who were using a Wi-Fi network other than PittNet, such as MyResNet Wi-Fi, Eduroam, or Pitt Guest Wi-Fi.

Pitt Digital is working to identify the root cause of the issue and take steps to address it. We continue to monitor the service closely and will post any additional updates to status.pitt.edu.

If you experience any issues with Pitt Print, please report them to them to the Technology Help Desk at +1 412 624-HELP (4357).
Posted Aug 22, 2025 - 12:49 EDT
This incident affected: Printing, Desktop and Mobile Computing, and Software (PittPrint).