Service Provider Issue Affecting Pitt Email
Incident Report for Pitt IT Systems Status
Resolved
This incident has been resolved.
Posted Dec 10, 2018 - 15:50 EST
Update
Microsoft has resolved the intermittent issue that affected access to Pitt Email for some students, faculty, and staff. Full service has been restored.
Posted Dec 10, 2018 - 15:49 EST
Investigating
Microsoft is experiencing an intermittent issue that is affecting access to Pitt Email for some students, faculty, and staff. Microsoft is aware of the issue and working to restore full service as quickly as possible. Updates will be posted as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Dec 10, 2018 - 12:56 EST
This incident affected: Email (Pitt Email and Calendar).