Service Provider Issue Affecting Access to Student Information System (PeopleSoft)
Incident Report for Pitt IT Systems Status
Resolved
Sierra-Cedar has resolved the issue that affected access to the Student Information System (PeopleSoft) earlier this morning. Full service has been restored
Posted Aug 20, 2019 - 10:33 EDT
Investigating
Sierra-Cedar is experiencing an issue affecting access to the Student Information System (PeopleSoft) and working to restore full service as quickly as possible. Updates will be posted as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Aug 20, 2019 - 08:42 EDT
This incident affected: Student Information System (PeopleSoft).