Monitoring confirms that the vendor's issue has been fully resolved.
Posted Nov 18, 2025 - 15:18 EST
Monitoring
Cloudfare implemented a fix that it believes has resolved the issue. PittPAY service appears to be recovering. Pitt Digital continues to closely monitor University services and will post additional updates to status.pitt.edu.
Posted Nov 18, 2025 - 10:00 EST
Identified
Pitt Digital is aware of a vendor issue that is affecting the ability of individuals to access some University services, including the Student Payment System (PittPAY). The service interruption is the result of a global issue with Cloudflare, a web infrastructure provider.
Cloudflare is working to resolve the issue, which is affecting individuals beyond the University of Pittsburgh. Pitt Digital will post updates to status.pitt.edu as more information becomes available.
Posted Nov 18, 2025 - 08:46 EST
This incident affected: Administrative and Business Systems (Student Payment System (PittPAY)).