Monitoring confirms the issue has been fully resolved.
Posted Mar 12, 2026 - 09:39 EDT
Monitoring
Pitt Digital has taken steps to mitigate the issue affecting PittNet Wi-Fi. Full service has been restored.
We continue to closely monitor service to ensure continued reliability and stability. Any additional updates will be posted to status.pitt.edu.
If you continue to encounter issues with PittNet Wi-Fi, please report them to the Technology Help Desk at +1-412-624-HELP (4357).
Posted Mar 11, 2026 - 12:46 EDT
Investigating
Pitt Digital is aware of an intermittent issue that is affecting PittNet Wi-Fi service on the Pittsburgh campus. MyResNet Wi-Fi is not affected. We are working to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Mar 11, 2026 - 12:31 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wi-Fi).