Issue Affecting Access to Pitt Worx System for Some Users
Incident Report for Pitt IT Systems Status
Resolved
Pitt IT has worked with the service provider to fully resolve the issue that affected access to Pitt Worx this morning. Full service has been restored. We continue to monitor the issue and will post additional updates to status.pitt.edu as they become available.
Posted Jul 01, 2022 - 12:05 EDT
Update
Pitt IT has implemented a change to mitigate the issue that affected access to Pitt Worx this morning. Time entry services have been restored, but other services may still be unavailable as we continue to work with the service provider to fully resolve the issue.
Posted Jul 01, 2022 - 11:38 EDT
Monitoring
Pitt IT has implemented a change to mitigate the issue that affected access to Pitt Worx this morning. Service has been restored. We continue to monitor the issue and will post additional updates to status.pitt.edu as they become available. If you are still experiencing issues accessing Pitt Worx, please report them to the 24/7 IT Help Desk at 412-624-HELP (4357).
Posted Jul 01, 2022 - 11:33 EDT
Update
Pitt IT continues to work with the service provider to resolve the issue. As a temporary workaround, individuals experiencing the issue can turn off Wi-Fi service on their mobile device and use their cellular service to access Pitt Worx. Additional updates will be posted to status.pitt.edu as they become available.
Posted Jul 01, 2022 - 10:49 EDT
Investigating
Pitt Information Technology is aware of an issue that is affecting access to Pitt Worx, the University’s human resources and payroll system, for individuals on campus who are using PittNet Wired and PittNet Wi-Fi.

Pitt IT is engaged with the service provider and working to resolve the issue as quickly as possible. Updates will be posted to status.pitt.edu as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Jul 01, 2022 - 09:08 EDT
This incident affected: Pitt Worx.