Service Provider Issue Affecting Box (pitt.box.com)
Incident Report for Pitt IT Systems Status
Resolved
Pitt IT's monitoring has confirmed that Box services have been fully restored.
Posted Oct 19, 2020 - 19:29 EDT
Monitoring
Box is reporting that it has resolved the issue that affected access to its services earlier today. Pitt Information Technology continues to monitor the service.
Posted Oct 19, 2020 - 15:45 EDT
Investigating
Box is experiencing an issue that is affecting the ability of users to access the service and upload and download content.

Box is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Oct 19, 2020 - 10:18 EDT