Issue Affecting My Pitt Access
Incident Report for Pitt IT Systems Status
Resolved
The issue that affected access to My Pitt (my.pitt.edu) earlier today has been resolved. Full service has been restored.
Posted Aug 07, 2019 - 12:50 EDT
Investigating
An issue is affecting access to My Pitt (my.pitt.edu) for some University users.

Pitt Information Technology is working to resolve the issue as quickly as possible. Updates will be posted as they become available.

Please contact the 24/7 IT Help Desk at 412-624-HELP (4357) if you have any questions regarding this announcement.
Posted Aug 07, 2019 - 11:08 EDT
This incident affected: My Pitt website (my.pitt.edu).