Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 02, 2026 - 23:00 EDT
Scheduled
Facilities Management has scheduled electrical maintenance that will interrupt power to the Cathedral of Learning from 11 p.m. tonight (April 2), until 7 a.m. on Friday, April 3. The building will be closed between these times.
During this maintenance PittNet Wi-Fi and PittNet wired service — as well as access to Computing Labs located in the Cathedral of Learning — will be unavailable. Network service to other campus locations will not be affected. In the event of any significant changes or delays, updates will be posted to status.pitt.edu.
Posted Apr 02, 2026 - 08:27 EDT
This scheduled maintenance affected: Printing, Desktop and Mobile Computing, and Software (Computing Labs / Virtual Lab) and Wired and Wi-Fi Networks (PittNet Wired Network, PittNet Wi-Fi).