Pitt Digital has taken steps to address the issue that affected PittNet Wi-Fi service for users of PittNet VPN (GlobalProtect) earlier this morning. Full service has been restored. We continue to closely monitor affected services and will post any additional updates to status.pitt.edu.
If you continue to encounter issues with GlobalProtect, please report them to the Technology Help Desk at +1-412-624-HELP (4357).
Posted Mar 16, 2026 - 10:01 EDT
Investigating
Pitt Digital is aware of an issue that is affecting PittNet Wi-Fi service for users of PittNet VPN (GlobalProtect). MyResNet Wi-Fi service is not affected. We are working to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more details become available.
Posted Mar 16, 2026 - 09:09 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wi-Fi) and Network, Hosting, and Storage (PittNet VPN (GlobalProtect)).