Issue Affecting Pitt Passport Single Sign-On Service
Incident Report for Pitt IT Systems Status
Resolved
Monitoring confirms that the issue has been resolved and full service has been restored.
Posted Apr 01, 2021 - 06:37 EDT
Monitoring
Pitt IT has taken steps to address the issue that affected the ability to log in to some services with Pitt Passport. Our monitoring indicates services are now stable. We continue to monitor the service and will post additional updates to status.pitt.edu, as needed.
Posted Mar 31, 2021 - 11:18 EDT
Investigating
Pitt Information Technology is aware of an issue affecting the ability to log in to some services with Pitt Passport, the University’s single sign-on service.

We are working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Mar 31, 2021 - 10:47 EDT
This incident affected: Pitt Passport (Single Sign-On).