Issue Affecting Concur Travel and Expense Management
Incident Report for Pitt IT Systems Status
Resolved
Monitoring confirms that the issue has been resolved.
Posted Dec 05, 2022 - 17:26 EST
Monitoring
The service provider has taken steps to resolve the issue and restore service. Pitt IT continues to monitor the service and will post additional updates to status.pitt.edu as needed.
Posted Dec 05, 2022 - 13:30 EST
Investigating
Pitt Information Technology is aware of a new issue that is affecting access to the Concur Travel & Expense System.

The service provider is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.

Please contact the 24/7 IT Help Desk at 412-624-HELP if you have any questions regarding this announcement.
Posted Dec 05, 2022 - 11:53 EST
This incident affected: Concur Travel & Expense.