Intermittent Issue Slowing My Pitt Performance
Incident Report for Pitt IT Systems Status
Resolved
The intermittent issue that caused some users to experience slower than expected response times when logging in to My Pitt (my.pitt.edu) has been resolved. Full service has been restored.
Posted Apr 22, 2019 - 17:06 EDT
Investigating
An intermittent issue is causing some users to experience slower than expected response times when logging in to My Pitt (my.pitt.edu).

Pitt Information Technology is aware of the issue and working to restore full service as quickly as possible. Updates will be posted as they become available.

Please contact the 24/7 IT Help Desk at 412 624-HELP (4357) if you have any questions about this announcement.
Posted Apr 22, 2019 - 14:23 EDT
This incident affected: My Pitt website (my.pitt.edu).