Intermittent Issue Affecting PittNet Wi-Fi Access for Some University Users

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital has resolved the intermittent issue that briefly affected PittNet Wi-Fi service earlier today for some users. Full service has been restored. We continue to monitor affected services closely and will post any additional updates to status.pitt.edu.
Posted Nov 19, 2025 - 18:09 EST

Investigating

Pitt Digital is aware of an intermittent authentication issue that is affecting the ability of some individuals to log in to PittNet Wi-Fi, including Eduroam and Pitt Guest Wi-Fi. MyResNet Wi-Fi service is not affected.

Pitt Digital is working to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Nov 19, 2025 - 15:31 EST
This incident affected: Wired and Wi-Fi Networks (Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).