Power Outage at Children’s Hospital of Pittsburgh Affecting PittNet Wired and Wi-Fi Service

Incident Report for Pitt Digital Systems Status

Resolved

The vendor has resolved their power issue. PittNet wired and Wi-Fi services have been restored to Children's Hospital of Pittsburgh. Pitt Digital continues to closely monitor affected services and will post any additional updates to status.pitt.edu as needed.
Posted Mar 24, 2026 - 15:58 EDT

Update

The vendor continues working to restore power. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Mar 24, 2026 - 14:48 EDT

Investigating

A commercial power provider serving the University of Pittsburgh and UPMC is experiencing an issue that has disrupted power to Children’s Hospital of Pittsburgh. As a result, PittNet wired and Wi-Fi service are currently unavailable at Children’s Hospital of Pittsburgh.

The vendor is working to resolve the issue and restore power. Network service will be restored as quickly as possible once power is available. Updates will be posted to status.pitt.edu.
Posted Mar 24, 2026 - 12:40 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wired Network, PittNet Wi-Fi).